Usar complementos antiguos en Firefox 4.0

Uno de los mayores inconvenientes para utilizar las versiones, hasta ahora beta, de Firefox 4 es que todavía faltan muchos complementos, extensiones, add-ons o como cada cual los llame por ser compatibles. Sin embargo esa compatibilidad se puede forzar bajo el riesgo de que el navegador pueda dejar de funcionar. Para ello lo que se hace es descargar el complemento y editar la parte correspondiente a la máxima versión con la que funciona. El apaño funciona para Firefox e Iceweasel, para otros derivados no lo sé.

Por ejemplo en el caso de BatchDownload, muy útil para descargar gran cantidad de imágenes fácilmente:

  1. Descargar el archivo .xpi que contiene el complemento.
  2. Abrirlo con WinZip, WinRAR, File Roller u otro programa de abrir archivos comprimidos.
  3. Dentro del comprimido abrir con el Bloc de notas, Gedit u otro editor de texto el archivo install.rdf
  4. Buscar la etiqueta <em:maxVersion> correspondiente a Firefox, ignorando las de Mozilla o SeaMonkey, y cambiar donde pone 3.7a1pre por 4.0.* y guardar el archivo.
  5. Guardar los cambios en el archivo comprimido.
  6. Abrir el comprimido con Firefox para instalar el complemento y reiniciar la aplicación.

Y a disfrutar. En caso de que el navegador no se abra habrá entonces que iniciarlo en modo seguro y quitar el complemento problemático desde el panel que los gestiona.

ACTUALIZACIÓN: dejó de funcionarme la chapuza, pero añadiendo una preferencia que vi en My Digital Life vuelve a funcionar:

  1. Introducir en la barra de direcciones about:config y pulsar intro.
  2. Clic derecho → Nuevo → Booleano.
    1. Nombre: extensions.checkCompatibility.4.0b
    2. Valor: falso.
  3. Reiniciar el navegador.

Fuente → Brit In Jerusalem

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *